PDFsharp & MigraDoc Foundation
https://forum.pdfsharp.net/

PDF file being opened by v1.32 fails to open by v1.50 stable
https://forum.pdfsharp.net/viewtopic.php?f=3&t=4262
Page 1 of 1

Author:  ta221 [ Sat Jun 19, 2021 9:20 am ]
Post subject:  PDF file being opened by v1.32 fails to open by v1.50 stable

Hello,

There is a PDF file which I was able to open properly using v1.32 of PDFsharp but it failed to open using v1.50 stable :(.

Result of attempt to open the file:
PdfSharp.Pdf.IO.PdfReaderException: Invalid entry in XRef table, ID=5, Generation=0, Position=0, ID of referenced object=1, Generation of referenced object=0

I don't know to explain how, but opening the file properly using v1.32, then saving the file and then attempting to open the saved version using v1.50 was the solution to resolve that automatically (otherwise, saving as using Adobe reader).

It's quite strange to say that the file could be opened properly using an earlier version (and somehow the earlier version "fixed" the file on saving).
Do you have an idea?

I believe you probably need the file for testing...

Thank you for your attention!

Author:  ivans [ Tue Jan 04, 2022 1:21 pm ]
Post subject:  Re: PDF file being opened by v1.32 fails to open by v1.50 st

@ta221 We have exactly the same problem. We have quite a few pdfs that can be opened using PdfSharp version 1.31.1789.0 but cannot be opened with version 1.50.5147 (error = Invalid entry in XRef table, ID=xx, Generation=0, Position=0)

I have yet to try your solution or latest beta version 1.51.5185.

Have you found anything else regarding the matter?

Author:  Kfirsde [ Tue Jul 05, 2022 7:01 pm ]
Post subject:  Re: PDF file being opened by v1.32 fails to open by v1.50 st

This problem still exists. For now, I'm using 1.32 but I would like to update it. Have someone found a solution?

Author:  Thomas Hoevel [ Tue Sep 13, 2022 6:56 am ]
Post subject:  Re: PDF file being opened by v1.32 fails to open by v1.50 st

The PDF files are corrupt.
Version 1.50 makes more consistency checks than version 1.32.
You can take the latest source code and disable the consistency check.

The files should work fine when you open them with Adobe Reader and use "Save as" in Adobe Reader to let it fix the inconsistency.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/