PDFsharp & MigraDoc Foundation

PDFsharp - A .NET library for processing PDF & MigraDoc Foundation - Creating documents on the fly
It is currently Sun Oct 22, 2017 3:21 pm

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Mon May 23, 2016 10:25 pm 
Offline

Joined: Thu Apr 23, 2015 2:08 am
Posts: 5
Hello,

I have an application that merges PDF files, creates title pages and adds bookmarks to the compiled document. This has always worked as expected for me with the previous version 1.32.

Yesterday I updated to the v1.5 (beta 3b) release from Sourceforge. All other functionality seems to work fine but no bookmarks (outlines) are inserted using the same documents and no changes to the code. There are no errors generated. If I disable the option in my program to insert files and just create bookmarks and title pages, it only creates the title pages.

If I revert back to v1.32, it all works fine again.

Please let me know if you need more information.

Thanks,

Randy


Last edited by argee on Sun Nov 06, 2016 4:33 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
PostPosted: Tue May 24, 2016 7:56 am 
Offline
empira Employee
User avatar

Joined: Mon Oct 16, 2006 8:16 am
Posts: 2720
Location: Cologne, Germany
Hi, Randy!
argee wrote:
Please let me know if you need more information.
Please provide a solution (incl. PDF files) that allows us to replicate the problem.

See also:
viewtopic.php?f=2&t=832

_________________
Regards
Thomas Hoevel
PDFsharp Team


Top
 Profile  
Reply with quote  
PostPosted: Wed May 25, 2016 2:36 am 
Offline

Joined: Thu Apr 23, 2015 2:08 am
Posts: 5
Thanks for the quick reply!

I think I'll have to do some digging to figure this one out. I made a simple test example that creates a single page with a bookmark and it works fine with v1.5.

If I disable certain options within my application which create some initial bookmarks for my title page and index page then all the rest of the bookmarks are created. As mentioned, no errors are being generated when the bookmarks are not created, so this is a tough one to pinpoint.

It all works fine with any options selected when using v1.32.

Do you know if anything about the way outlines are created or handled was changed from v1.32 to v1.5?

Thanks,

Randy


Top
 Profile  
Reply with quote  
PostPosted: Wed May 25, 2016 8:18 am 
Offline
empira Employee
User avatar

Joined: Mon Oct 16, 2006 8:16 am
Posts: 2720
Location: Cologne, Germany
argee wrote:
Do you know if anything about the way outlines are created or handled was changed from v1.32 to v1.5?
I don't recall any intentional changes.

_________________
Regards
Thomas Hoevel
PDFsharp Team


Top
 Profile  
Reply with quote  
PostPosted: Thu May 26, 2016 1:33 am 
Offline

Joined: Thu Apr 23, 2015 2:08 am
Posts: 5
After further investigation, I think I may have found the problem.

The two initial bookmarks I was adding both had a carriage return in the outline title text (in Visual Basic - vbCrLf). The title text is something like "test bookmark" & vbCrLf & "2nd line". If I make those outline titles single line then everything works as expected.

I attached a little VB.Net test project that attempts to add an outline with 2 lines of text in the title or an outline with only a single line of text in the title. The attempt to add a 2-line outline title does not work, the single line does.

This is a change from v1.32 where the multiple line titles worked. Do I need to format my text differently?

Note: In the attached project I removed the PDFSharp.dll file from the \bin\Debug\ folder to keep the upload small enough

Hope this helps!

Thanks,

Randy


Attachments:
TestBookmark.zip [100.42 KiB]
Downloaded 109 times
Top
 Profile  
Reply with quote  
PostPosted: Mon Oct 24, 2016 1:28 pm 
Offline
empira Employee
User avatar

Joined: Mon Oct 16, 2006 8:16 am
Posts: 2720
Location: Cologne, Germany
As far as I can tell, this problem only occurs with the DEBUG build of PDFsharp up to 1.50 beta 3b.
Bookmarks with two lines work when using the RELEASE build or NuGet packages (which contain the RELEASE build).

With the next release, this issue will also be resolved for the DEBUG build.

_________________
Regards
Thomas Hoevel
PDFsharp Team


Top
 Profile  
Reply with quote  
PostPosted: Sat Oct 29, 2016 5:02 am 
Offline

Joined: Thu Apr 23, 2015 2:08 am
Posts: 5
Yes, I just downloaded the latest package from NuGet and tried it with my test application and it now works!

Thanks!


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group